Customer Support Phone Outage

Incident Report for Gabb

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 18:19 UTC

Identified

We’re currently experiencing intermittent issues with our phone system. Our chat team is ready and available to help—please visit gabb.com to start a chat with a Gabb Expert.
Posted Nov 10, 2025 - 16:13 UTC
This incident affected: Customer Support Phone Line.