Customer Support Phone System

Incident Report for Gabb

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 03:22 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 21:06 UTC

Investigating

We’re currently experiencing an issue impacting our customer support phone lines. We've temporarily turned off our phone lines. Our team is actively working to resolve the issue as quickly as possible.
Posted Oct 20, 2025 - 14:58 UTC
This incident affected: Customer Support Phone Line.