Some customers are experiencing issues logging in to their account

Incident Report for Gabb

Resolved

We have resolved the issue with customers not being able to log in. Please refresh your page or restart your app and try again.
Posted Mar 19, 2025 - 01:14 UTC

Investigating

Some customers cannot login to their account at this time. We are actively investigating. Sincere apologies. Please subscribe for updates or check back at a later time.
Posted Mar 18, 2025 - 22:30 UTC
This incident affected: gabb.com, Gabb ID, and Gabb Messenger.