Gabb Watch: Issue with contacts, slower performance, and call/text history

Incident Report for Gabb

Monitoring

We have released an update to customers who were experiencing issues with contacts disappearing from their watch, other contact management issues, as well as disappearing call/text history on the watch.

To ensure you receive the update:

1. Make sure your MyGabb parent app is updated (check your app store)
2. Put your child's watch on its charger
3. Connect the watch to WiFi
4. On the watch, tap the "ID" app
5. Tap "Update Apps" and wait up to 15 minutes for the update to complete
6. Once the update is complete, power your watch off and on

These updates aim to resolve contact management issues (i.e. contacts disappearing) with your Gabb Watch

We are now actively monitoring these recent fixes.
Posted Jul 03, 2025 - 23:06 UTC

Update

Our engineering team continues working daily on the contact management issues on Gabb Watches. We're currently in the testing phase to ensure these solutions work reliably across all devices and network conditions before release.

We'll notify you immediately when fixes are validated and ready to deploy.

Thank you for your continued patience
Posted Jun 24, 2025 - 23:33 UTC

Update

After non-stop intensive investigation into these complex technical issues, we have identified the root causes affecting contact management on Gabb Watches. Our engineering team is now working to implement targeted fixes for contact synchronization and call routing problems. We will provide further updates as these fixes roll out to customers. We understand this issue has persisted longer than expected and deeply apologize for the continued impact on families. We will notify subscribers immediately when the fixes are live.
Posted Jun 18, 2025 - 00:34 UTC

Identified

We have identified and resolved the issue some customers were experiencing with their primary (account holder) and other contacts not appearing on their Gabb Watch. While we have fixed this issue, we are aware that some users with recent versions of the Gabb Watch software may still be experiencing the following issues:

Contact-Related Issues
- Contacts appearing in the MyGabb App but not displaying on the Watch
- Ability to make outgoing calls and texts to contacts, but inability to receive incoming calls and texts from those same contacts
- Incorrect contact being called when attempting to call a different contact

Performance Issues
- Watch operating slower than normal
- Launcher screen problems, including missing or unresponsive screens
- Call history and message history not displaying properly

Our technical team is actively working to resolve these remaining issues. We will continue to monitor the situation and provide updates as we make progress. We sincerely apologize for any customers impacted. Please subscribe to receive updates as we continue to progress
Posted Jun 04, 2025 - 23:05 UTC

Update

We are continuing to investigate this issue
Posted Jun 04, 2025 - 23:04 UTC

Investigating

Some customers are experiencing contacts not showing up (or disappearing) on their child's Gabb Watch. We apologize and are actively investigation the issue. Please subscribe to this issue to be texted for updates.
Posted May 22, 2025 - 23:26 UTC
This incident affects: App Management and Gabb Watches.