Customer Support Phone System Down

Incident Report for Gabb

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:10 UTC

Investigating

Due to issues with AWS and Google Cloud having issues across the entire web right now, our phone system is down. We will have it back up the moment we are able.

We deeply apologize for the inconvenience. You can still chat us at gabb.com/support!
Posted Jun 12, 2025 - 19:15 UTC
This incident affected: Customer Support Phone Line.